Archived Forum Post

Index of archived forum posts


Intermittent issues while connecting to SFTP.

May 09 '16 at 16:10

Hello, My IIS webservice application connects to SFTP using ChilkatVersion: It is able to get the documents however it intermittently fails with following error.

    DllDate: Dec  5 2014
    UnlockPrefix: ********
    Username: <user name="">
    Architecture: Little Endian; 32-bit
    Language: .NET 2.0
    VerboseLogging: 0
    SftpVersion: 0
    hostname: <host ip="" address="">
    port: 22
    Established TCP/IP connection with SSH server
    clientIdentifier: SSH-2.0-PuTTY_Release_0.63
    Sending client identifier...
    Done sending client identifier.
    Reading server version...
    Failed to read initial server version string

What i am not able to understand is what may cause this error to occur intermittently.

Could this be issue with Chilkat version or something to do with SFTP server.

Please help!

[EDIT 5/9/15]

Alright, i did following test, please see if you can help with this information.

This is the process I am trying to test. My webspplication runs on IIS which calls an SFTP server for some files. This is a webservice called by clients.

When i run this application on Win2k3 server with IIS 6, out of 200 calls i see this exception happening for 6-7 odd times I migrated this application as is on Win2k8 server with IIS 7.5 When I run it there, is see this exception happening for around 40 times out of 200 same calls.

Any clue why it may?

I am being told not to change the webservice code while doing migration, hence code change by upgrading Chilkat will be a last resort.

Please help!!

Thanks Santosh


This part looks a bit fishy:

[code] hostname: <host ip="" address=""> [/code]

Maybe part of your code is failing to set the host/IP of the server occassionally?

Another thing is that you are using a slightly outdated version of the Chilat library. If you try again with the latest version does it help?