Archived Forum Post

Index of archived forum posts


Error sending mail using SendQ2

Jun 02 '16 at 21:47


I got below error when trying to send mail using SendQ2.

The application is a 32bits classic ASP Web application running in MS Server 2008 R2 Standard 64bits OS.

Below is the error I got:

DllDate: Mar 11 2016
 UnlockPrefix: anything for 30-day trial
 Username: KOS-IIS4:kosadmin
 Architecture: Little Endian; 32-bit
 Language: ActiveX
 VerboseLogging: 0
xSigningAlg: sha1
 Auto-generating Message-ID

 SmtpPort: 25
 SmtpSsl: 0
 StartTLS: 0
 SmtpQHeaders: x-sendMime: yes x-from: x-bounceAddr: x-recipients: x-smtpPort: COPcCJqYTCoLtnEAN1rAQ4aMmfL/M2/jZVX62XAD1tI= x-smtpHost: 9agChCj8myf0yrZv27eVW44pYbfJgTidTYNsMltrbSgzmzNswb3p19ujanKrkSx+ x-sendIndividual: yes x-startTls: no x-ssl: no x-autoGenMsgId: yes x-SMTPQ-Version:
 SendQFilename: D:\Temp\ChilkatSmtpQ\queue\e_20160601_081649_93f76b0012837D4FB.eml
 WindowsError: Access is denied.
 WindowsErrorCode: 0x5
 win32CreateFileAnsi failed.
 localFilePath: D:\Temp\ChilkatSmtpQ\queue\e_20160601_081649_93f76b0012837D4FB.eml
 currentWorkingDirectory: C:\Windows\SysWOW64\inetsrv
 localWindowsFilePath: D:\Temp\ChilkatSmtpQ\queue\e_20160601_081649_93f76b0012837D4FB.eml
 filename: D:\Temp\ChilkatSmtpQ\queue\e_20160601_081649_93f76b0012837D4FB.eml
 Failed to write complete file (7)
 Failed to write EML file.

Accepted Answer

Your server-side classic ASP does not have permission to create files in D:TempChilkatSmtpQqueue\

Create a virtual directory in IIS with the correct permissions, and then pass the virtual directory path to SendQ2.


Thanks for reply.

The problem is finally solved. I found out the "Anonymous" authentication was not enabled for my web site and after enable it, the problem is solved.