Archived Forum Post

Index of archived forum posts


HTTP ActiveX component error uploading to S3

Jul 22 '16 at 11:52

I'm using the HTTP ActiveX component in a VBS script to upload files from the local system to Amazon S3. This has been in place and functioning properly for some time, but recently I began to notice issues.

In this specific case, I'm trying to upload a .rar file that's approx 3.9 GB.

The upload process starts when I call the S3_UploadFile method, runs for about 110 minutes and then returns the error linked below:

I've tried uploading other files as small as a few KB and receive the same error.

How can I go about troubleshooting and correcting this issue?


I think the 1st thing to do is to test with the latest version of Chilkat (v9.5.0.58).

However, given the extreme size of the file, I think the best approach is to use the Chilkat REST API to upload in parts (see )

What I plan to do is to write examples for you do demonstrate using the REST API to upload the large file in parts, and also a way to re-run to upload those parts that failed. This way it's never an all-or-nothing result. Writing the examples will take some time, and I think I'll need to add a feature to the Chilkat Stream API so that a stream can be just a part of a file..


Thanks for the suggestion, but as noted I've also tried with files as small as a few KB and experience the same result, so it doesn't apppear to be related to filesize. Any other suggestions?


Yes. This is very likely a Windows Firewall issue. See

(The information about the Windows Firewall issue pertains to a case using FTP, but I also think the same problem applies to HTTPS)


Unfortunately, Windows Firewall is disabled on the system in question - should've mentioned that. Anything else?


Something's interfering with the connection...