Archived Forum Post

Index of archived forum posts


CSR is invalidate to apply for CA's certificate

Mar 10 '17 at 00:16

The CSR created by using CkCSR is invalidate to apply for CA's certificate.

I've tried Comodo, RapidSSL, StartSSL and got the same results due to invalidate signature.

I alse copy the CSR sample post on

There is a same error occured: invalidate signature.


Please let me know what operating system, and if Windows, which version of VC++ you're using. I'll create a pre-release of v9.5.0.66 for you to test. This may be a problem that was already fixed..


Windows 10, VS2013(VC12),



Please give this new build a try:


Hi Chilkat, I've tried just now. The result is "Signature Not Valid"

Maybe you can use this online tool to check.


I found the problem and fixed it. It's very strange because this was working for various customers. I noticed that it was generating a signature using the little-endian byte ordering, which makes no sense because everything would normally be big-endian except historically Microsoft's Crypto API (not w.r.t. to CSR's, but with RSA in general..)

The fix was to just flip a switch from true to false within the code..

I'll rebuild, re-upload, and post the download links again when ready..


This new build should fix it:


Great! It works now. Thanks