Archived Forum Post

Index of archived forum posts


ProFTPd problem

Aug 12 '13 at 21:57

Problem with ProFTPd shown below was reported to be solved by modifying ProFTPd configuration, according to Chilkat blog (

425 Unable to build data connection: Operation not permitted

Is there any workaround for the problem on Chilkat side? WinSCP 5.1.6 avoids the problem, so there seems to be a workaroud on client side. I encounterd the problem with ProFTPd embedded in a NAS, which does not allow users to modify ProFTPd configuration.

I'm using FTP2 activeX component 9.4.0.


When Chilkat implements SSL/TLS session re-use in the underlying SSL/TLS implementation, then it will be solved. This is on Chilkat's task list...


I do await your earliest implementation!

Without it, I'll have to rewrite many apps by the end of September to implement SFTP in addition to already implemented FTPS which have been working well.

I updated the firmware including many security patches of NAS without knowing the change in ProFTPd, because it was not announced by the vendor.

I'm also waiting the reply from the vendor whether it is possible or not to rollback firmware, which was not in the older products from the same vendor, or to modify ProFTPd configuration somehow.