Archived Forum Post

Index of archived forum posts


SFTP downloads zero bytes for some servers

Jan 31 '14 at 09:11

I am using ChilkatDotNet4 v9.4.0.0 with VB .NET. This is being run as a Windows Service.

We have many sites where we are downloading files and the service works fine. I have now encountered 2 sites with this same problem.

It creates the local file, but it is zero bytes. I can get the file size and see it is 1337 bytes, or whatever, but it won't download. In testing, it seems to hang.

I have tried changing it to just grab 100 bytes instead of downloading the whole thing, and I get the same response. I have tried running the service logged in as a user, no help.

I can connect using Filezilla and download with no problems.

The permission on the file I am trying to get is: 33526

Here is the output from after the download fails, although it is showing success:

ChilkatLog: ReadFileText: DllDate: Dec 12 2012 UnlockPrefix: ALLMEDSSH Username: USER-PC:me Architecture: Little Endian; 32-bit Language: .NET 4.0 VerboseLogging: 0 SshVersion: SSH-2.0-WS_FTP-SSH_7.5.1 FIPS SftpVersion: 3 handle: 313535 charset: ansi numBytes: 100 nextReadIdx: 0 downloadLoop: socketOptions: SO_SNDBUF: 64512 SO_RCVBUF: 8192 TCP_NODELAY: 8193 --socketOptions startingOffset: 0 numBytesToDownload: 100 bReadUntilEnd: 0 Unexpected status response (2) statusCode: 100 timeToDownloadFileDataMs: Elapsed time: 31 millisec --downloadLoop NumBytesSentToOutput: 0 newNextReadIdx: 0 numBytesReceived: 0 Success. --ReadFileText --ChilkatLog


  1. Show the verbose LastErrorText for the latest version (v9.4.1). Verbose logging is obtained by setting the VerboseLogging property = true.
  2. Post the LastErrorText in "pre" tags so that it's readable.
  3. Check to see if DownloadFileByName produces different results.
  4. Check to see if ReadFileBytes produces different results.


See if you can get the what ssh server and libs version that you are getting the bad files. We have encountered major issues with some ftp servers especially when the ssh libs are old and out of date.