Archived Forum Post

Index of archived forum posts


SendEncrypted Mail not working VCPP SP1

Sep 09 '14 at 09:57

I did try to send a signed mail (worked) and after that I did try to send an encrypted mail, but this task failed.

email.put_SendSigned(true); //worked
email.put_SendEncrypted(true);//did fail

If I try to encrypt while loading (via LoadFromFile) my exported crt-File it worked, but I would prefer the way you mention in your documentation (see below)

Your Documentation said it should work, because the Cert is stored and visible via certmgr.msc. I am able to sign + encrypt via Outlook as well.


// In this example, we've already installed the certificate for "" // in the current user's personal certificate store. // If the email.SendEncrypted property is set, Chilkat will // automatically search for and use the first non-expired certificate // matching the recipient's email address. Chilkat searches // the Current User's Personal certificate store, as well // as the Local Machine's Personal certificate store. // Run certmgr.msc to view the certs in the Current User's // certificate store. email.put_SendEncrypted(true);


Examine the contents of the mailman.LastErrorText property after calling SendEmail to get more information about the problem.