Archived Forum Post

Index of archived forum posts


iOS ftp "Failed to start thread"

Oct 14 '14 at 10:17


We're using CkoFtp2 to download a large number of files (about 15k). They're downloaded on Async Active mode. After some time, AsyncGetFileStart consistently returns an error saying "Failed to start thread". We've tried creating a new ftp object or using the same one, using the same connection or reconnecting, but the same thing always happens after a few thousands download. It's happening on both iOS7 and 8.

We're out of ideas to diagnose the issue, any idea what could go wrong?



I think Chilkat FTP was releasing the threads but not the sockets, and the application ran out of them.

Having no answer from the support, we had to redevelop it, so we shouldn't have paid for it!!


Hi Sylvain, sorry your experience has left you unhappy, but as a fellow customer I must disagree with your assessment. Chilkat's library is a fantastic value that provides such a wide range of functions for the price that it is hard not to be impressed. Browse this forum and you will see that support is typically excellent when the right information is received to help Chilkat identify and solve the problem. Micro-updates are frequently released to address any issues.

Now you may have found a bug, and I understand that is frustrating, but show me any piece of sufficiently complex software that doesn't have some bugs? Especially for a library that ends up having to interact with all sorts of other potentially buggy software from other vendors/sources (such as the myriad HTTP/FTP/SFP/Etc... servers out there). The important thing is that when bugs are found, they get fixed, and Chilkat does an exemplary job of this typically. The issue is that you still haven't provided enough information for anyone to help you. If you read the side bar, it mentions (at a minimum) posting the full contents of the LastErrorText property immediately after a failing call, as well as ensuring you are working with the latest build of the library (in case the "bug" has already been fixed). I also think it is good form to post a small code snippet that demonstrates the problem, just in case the problem is not due to a bug, but rather a logic/coding error.

Regarding Codejock's non-response - he says he didn't receive the unlock code by email, you said you sent it. Maybe it got eaten by a spam filter? In any case it sounds like you got no response, because Chilkat got no response. Trust me, without getting confirmation of your unlock code, Chilkat would be run ragged helping pirates and other freeloaders frequently (I've personally had people send me private messages on other forums asking me to share my Unlock Code so that they could use the library, try and get support, etc... Naturally I've refused such requests, but you can be sure that some of these people come to this forum trying to suck some free support out of Chilkat. I can only guess at how many "fradulent" requests for support Chilkat gets at the support email address, but I suspect even just responding to all of them would eat up a lot of time.

I should add that I am also a customer who has let my support license lapse. When you do this, you must understand that it is "at your own risk" - you must be prepared to solve your own problems. If you encounter a situation that you think is being caused by a bug, the least you can do is post detailed information to the forum (as described above) and hope that either someone else has experienced the problem and worked around it, or can spot a logic error, or that if it is indeed a library bug then there's a good chance that Chilkat will be able to fix it and release an update. AFAIK since you bought your license before the recent changes to the Chilkat license, you are entitled to free updates for already purchased components, so you will get the fixed build at no extra financial cost - but you must be willing to do your part to help identify and solve the problem (a time cost).