Archived Forum Post

Index of archived forum posts


SMTPQ stuck while sending mails

Mar 12 '15 at 08:52

Don’t know if I’m on the right track but I had a problem with SMTPQ when sending to distributions lists with 120+ emails. I tried the retry count from 0 to 10 but it would stop processing e-mails after (X) e-mails where sent. Had to restart the service so it would start sending again but on a number of occasions it would loose the E-mail that being processed (from our app to the queue) so an automated service restart routine solution was discarded. Then I set the maximum threads to 2 and it seems to be working ok but takes longer to send the e-mails. At least the last two distributions (500+ emails) on one of the clients have gone through with no problem. I’m using a Linux based e-mail ssmtp server as the relay agent and I set a limitation of 20 e-mail concurrent connections per client. My theory is that it would start sending e-mails exhausting the 20 connections slots and then freeze when it could not find a new connection to the server. Probably waiting for the retry delay etc.. Note that the clients use a regular DSL modem (512k upload speed) to connect to the server.

Anyone has tried this work around? Does the theory sound logical? Could this be a coincidence that does not have any relation to the actual problem? I really like the SMTPQ queuing mechanism and have it deployed on 20+ clients so a fix is less painful than changing to another queuing solution.

Feedback is really appreciated…