Archived Forum Post

Index of archived forum posts


RSA key size is too small

Jun 25 '15 at 09:24
AuthTls: 1
AuthSsl: 0

          sendingCommand: AUTH TLS
          replyLineQP: 234 start TLS negotiation
                RSA key size is too small.
                minAcceptableRsaSize: 1024
                tooSmallKeySize: 512
            Failed to build ClientKeyExchange
              Closing connection after sending fatal TLS alert.
        Client handshake failed. (1)
        connectionClosed: 0
        Failed to convert channel to SSL/TLS
    Failed to connect to FTP server.

How can I change minAcceptableRsaSize?


First, make sure you are using the latest version of the Chilkat library. Then I think the SslAllowedCiphers property might be what you need. I suggest appending "rsa512" to the list of allowed ciphers to see if that helps. See the documentation below:

SslAllowedCiphers As String Introduced in version

Provides a means for setting a list of ciphers that are allowed for SSL/TLS connections. The default (empty string) indicates that all implemented ciphers are possible: aes256-cbc, aes128-cbc, 3des-cbc, and rc4. To restrict SSL/TLS connections to one or more specific ciphers, set this property to a comma-separated list of ciphers such as "aes256-cbc, aes128-cbc". The order should be in terms of preference, with the preferred algorithms listed first. The server however, chooses from among the algorithms listed.

Starting in v9.5.0.48, Chilkat will by-default disallow all possible usage of RSA keys that are less than 1024 bits. To allow for 512 bits or above, add "rsa512" to the list of algorithms in the SslAllowedCiphers list. To allow only 2048 bits or above, add "rsa2048" to the list of algorithms. (Adding "rsa1024" chooses the same as the default.)