Archived Forum Post

Index of archived forum posts


How can I register my chilkat library on an Azure WorkerRole Virtual Machine?

Jan 26 '16 at 13:40

Hello, I'm updating my application to run in the Cloud and I have to use the encrypt and decrypt functions in my chilkat library.

My project references Interop.CHILKATCRYPT2Lib.dll. I'm using it in a 64 bit windows virtual machine on Azure.

When I call my service I get the following error.

Retrieving the COM class factory for component with CLSID {3352B5B9-82E8-4FFD-9EB1-1A3E60056904} failed due to the following error: 80040154 Class not registered (Exception from HRESULT: 0x80040154 (REGDB_E_CLASSNOTREG)). Method: Global_DecryptSecureItem

I have tried to register the assembly on the machine using regsvr32, however it returns this error:

The Module was loaded but the entry-point DLLResigterServer was not found.

EDIT I found a CryptActiveX windows installer on our server and ran that on the Virtual Machine. After running that I was able to successfully regsvr32 the following 3 libraries that I also found: ChilkatCert.dll ChilkatCrypt2.dll ChilkatUtil.dll

However, I get the same error when I run my code - and I still get the same error when I try to regsvr32 the referenced library Interop.CHILKATCRYPT2Lib.dll

Can you please guide me in the steps to correctly register this library for my required environment?

Thank you,



Registration requires the ActiveX version of the Chilkat library, and the The Module was loaded but the entry-point DLLResigterServer was not found. message usually appears when you call regsvr32 against a non-ActiveX library.

Another problem might be that you have installed the 32-Bit ActiveX but need to use the 64-Bit build (or vice versa).


The DLLs you mention are old versions of Chilkat. For many versions now, the Chilkat ActiveX is a single DLL that contains all the Chilkat classes.

In any case, the Chilkat ActiveX DLL's (both old and new) are standard self-registering ActiveX DLLs. Any problems w/ registration can really be generalized to any ActiveX. In other words, if you have a problem with Chilkat_xyz.dll, then you would also have the same problem with Anything.dll



If you are correct I still have a problem which I'm not sure how to fix. Do you have any steps or advice for fixing this?

I'm also experiencing the issue running the code in an Azure Emulator released by Microsoft. I have no control over that code/machine, yet I need to be able to use the decrypt and encrypt methods.

When I instantiate the object: ChilkatCrypt2 crypt = new ChilkatCrypt2(); I get the error stated above in my first post.

What can I do on a system or in code to correctly instatiate the chilkatcrypt2 library?