Archived Forum Post

Index of archived forum posts


Email ActiveX Component keeps losing registration on Win8.1

Jan 14 '16 at 11:31

On July 1, 2015 we purchased the ChilkatAz-9.5.0-win32 Email component. We integrated that into a Visual Dataflex process, installed the 32-bit control as Administrator and parked that application on an older Windows XP machine for a few months which worked perfectly for the duration.

A week ago we registered the component and moved the same Visual Dataflex process using that same Chilkat component to a Windows 8.1 machine. Chilkat again registered fine and works perfectly, however every few days it complains that it is not registered and the error returned is DllRegisterServerFailed 0x80070005.

The problem is solved by running the 32-bit registration batch file as Admin once more, however the email backlog this creates is substantial. Thoughts?


If an ActiveX (any ActiveX) is unregistered, then it can only be that something on that system is doing it. An ActiveX wouldn't just spontaneously unregister. The only solution is to find out what offending software on that particular system is taking it upon itself to unregister ActiveX DLLs -- and then stop that software from doing it. It's impossible for me to know what it could be..


Looking up the error code 0x80070005 I see that is ACCESS DENIED, so the Chilkat registry keys may be there (not unregistered), they may just not reliably be readable by the application. Any experience with this type of issue in W8 and above? Kindly explain what the control is attempting to do to validate itself.


Perhaps you placed the DLL in a location that is not on a local hard drive? If the DLL is on a mapped drive or on a network share (i.e. something not managed by the local computer), then the DLL cannot be fully trusted. A process cannot just load executable code (from a DLL) that is located "out there" in the untrusted wilderness.